Instructor-Led Virtual Courses

Technical Requirements

Adobe Connect

Below are the technology requirements for students of RMC's Instructor-Led Virtual Courses. RMC currently uses a Virtual Classroom technology called Adobe Connect. For more detailed technical requirements and Adobe Connect customer support contact details, please Visit the Adobe Connect website by Clicking Here.

We suggest that users should install the most current Adobe Connect add-ins and also users should be on a wired connection if possible.
Check here for the most current Adobe updates.

Audio Requirements

Courses will be taught using VoIP (Voice over Internet Protocol). Each student must have ear/headphones and a microphone to participate. Using computer speakers creates a distracting echo for all participants. There is no phone connectivity for classes.

If you do not have ear/headphones, you will be offered the opportunity to purchase a set during the course registration process.

Technical Requirements
Requirement Microsoft® Windows® Apple® Macintosh®
Versions Supported: Windows 10
Windows 8.1 (32-bit/64-bit)
Windows 8 (32-bit/64-bit)
Windows 7 (32-bit/64-bit)
Mac OS X 10.8
Mac OS X 10.9
Mac OS X 10.10
Browsers Supported: Microsoft Internet Explorer 8 or later
Windows Edge Broswer
Mozilla Firefox
Google Chrome
(Adobe® Flash® Player 13.0+)
Apple Safari
Mozilla Firefox
Google Chrome
(Adobe® Flash® Player 13.0+)
Processor Speed: 1.4GHz Intel® Pentium® 4 or faster processor 1.83GHz Intel Core™ Duo or faster processor
Memory (Minimum): 512MB of RAM (1GB recommended) 512MB of RAM (1GB recommended)
Bandwidth Required: 512 Kbps 512 Kbps
Display (Minimum): 1024x768 or higher, with 16-bit color 1024x768 or higher, with 16-bit color

Mobile Requirements

Students who wish to use their mobile device must download the Adobe Connect App from the App Store or from Google Play.

Mobile Requirements
Requirement Apple® Devices Android® Devices
Devices Supported: iPhone 5S
iPhone 5
iPhone 4S
iPad with Retina display
iPad 3
iPad 2
iPad mini
iPod touch (4th & 5th generations)
Motorola DROID RAZR MAXX
Motorola Atrix
Motorola Xoom
Samsung Galaxy Tab 2 10.1
Samsung Galaxy S3 & S4
Nexus 7 tablet
Versions Supported: iOS 6 and higher Android version 2.3.4 and higher
Social Facebook
Twitter
LinkedIn
You Tube
Converging 360